Home / Command Line Interface (CLI) / Fixing W: GPG error: http://download.opensuse.org Release: The following signatures were invalid: KEYEXPIRED 1501595774 error

Fixing W: GPG error: http://download.opensuse.org Release: The following signatures were invalid: KEYEXPIRED 1501595774 error

I was trying to update one of my server that has some Opensuse repositories and received this error “W: GPG error: http://download.opensuse.org Release: The following signatures were invalid: KEYEXPIRED 1501595774”

Fixing W GPG error http download.opensuse.org Release The following signatures were invalid KEYEXPIRED 1501595774 error - blackMORE Ops - 1

root@someserver:~# apt-get update
.
.
.
---SNIP----
Ign http://download.opensuse.org  Translation-en
Fetched 481 B in 4s (97 B/s)
Reading package lists... Done
W: GPG error: http://download.opensuse.org  Release: The following signatures were invalid: KEYEXPIRED 1501595774

Ran some google search and found that you can simply update the new key from Ubuntu Keyserver.

root@someserver:~# apt-key adv --keyserver keyserver.ubuntu.com --recv 3050AC3CD2AE6F03
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.ppuZx4ZW8s --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/chris-lea-redis-server.gpg --keyring /etc/apt/trusted.gpg.d/ondrej-php.gpg --keyserver keyserver.ubuntu.com --recv 3050AC3CD2AE6F03
gpg: requesting key D2AE6F03 from hkp server keyserver.ubuntu.com
gpg: key D2AE6F03: "home:rtCamp OBS Project <home:rtCamp@build.opensuse.org>" 1 new signature
gpg: Total number processed: 1
gpg:         new signatures: 1

Next update try just worked after this

root@someserver:~# apt-get update
.
.
.
---SNIP----
Fetched 481 B in 5s (95 B/s)
Reading package lists... Done
root@someserver:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libssl-dev openssl
The following packages will be upgraded:
  git git-man update-manager-core
29 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
Need to get 5,806 kB of archives.
After this operation, 24.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y

Hope this helps someone else who’s had the same issue as I did.

Leave a Reply

Your email address will not be published. Required fields are marked *