Enable USB Boot in Gigabyte Motherboard

I’ve got this Gigabyte Motherboard GA-P35-DS3L (rev. 2.0) in my old desktop running Q6600 Quad Code CPU and 4GB RAM. Enable USB Boot in Gigabyte Motherboard - 10 - blackMORE OpsI’ve used this computer for last 5 years and to be honest, it’s still superb compared to some newer machines I’ve used recently. I installed Windows 7 and Kali Linux on it and after almost 2 years I decided it’s time to reformat and re-install everything from scratch. Easier said than done. I put a USB disk with Windows 7 on it and rebooted. My Gigabyte motherboard doesn’t detect it Live USB! I can honestly say, it did last time I tried. Naturally, I thought, I must’ve messed up my Live Windows 7 USB stick. So, I tried Linux (Kali Linux, Ubuntu, Arch .. you name it), still Gigabyte motherboard doesn’t detect any of the Live USB’s. I so started looking to motherboard to figure out how to enable USB boot in Gigabyte Motherboard.

Interestingly, this seems to be an ever growing issue for many different motherboards from different vendors. I went through almost all of the posts available in Google and Gigabyte website, but it seems there wasn’t any good solutions out there. Most people end up using a CD/DVD, but for me, I want to use USB Boot in Gigabyte Motherboard to make my installations faster. I can’t be bothered to install and re-install and burn CD/DVD every time I want to wipe my disks clean. Mostly, I am not good at keeping CD/DVD’s in a nice stacked and numbered order to be able to find them later on, I’m messy, so there you have it!

BIOS settings to enable USB Boot in Gigabyte Motherboard:

Gigabyte Motherboard GA-P35-DS3L (rev. 2.0) uses AWARD BIOS which is usually quite good. I updated my BIOS sometime back and never had any issues since. Enable USB Boot in Gigabyte Motherboard - 2 - blackMORE OpsHowever, I suspect during that BIOS update, it must’ve reset settings to safe-boot mode or similar which wipes out some of the config’s I had there. After much testing and reboots, following settings always seems to work for both Windows and Linux Live USB Boot in Gigabyte Motherboard.

  1. During boot sequence, press DEL key in keyboard and go to BIOS settings.
  2. Enable Integrated Peripherals > USB Legacy.
  3. Enable Integrated Peripherals > USB Storage.
  4. Set Boot Order to HDD, CD-ROM, Network.
  5. Now plug in Live USB Boot stick and reboot.
  6. Press F12 at the Boot Screen to bring up the Boot Menu.
  7. Choose HDD+ on the Boot Screen, don’t choose other USB options.
  8. Now choose your USB Device on the next screen and press ENTER.

This should take you to your Live USB Boot. Hope this helps someone out there. Thanks for reading. If you found this helpful, please share.

Check Also

How to fix You can’t access this shared folder because your organization’s security policies block unauthenticated guest access error on Windows 11

If you have the following error on Windows 11 “You can’t access this shared folder …

How to unhide menu bar in Virtualbox - blackMORE Ops - 2

How to unhide menu bar in Virtualbox

So I went in and hid the top menu bar and bottom status bar in Virtualbox. After they disappeared, now I cannot find out how to unhide those. Took me a little bit time to figure out, hence this post so that I don't forget it and someone else having the same to unhide menu bar in Virtualbox can find this.


  1. thanks Bro! it works!

    • I got frustrated with this particular motherboard. . This was the only solution that ever worked for me. . Worst part was, no one ever documented it.. Glad that it worked for at least one more person. . :-)

  2. Awesome. Thank you x

  3. Thanks a lot man!


  5. Thanks for the help. Works on Gigabyte EP43 UD3L with a little translation.

  6. Hi!

    I was struggling with this mother too. I just read your post and do what u said but still cannot boot from my usb. the only differences is that i don’t have the option “Integrated Peripherals > USB Storage” at least it’s not called that way, and neither the network option to boot (so i just set it to floppy). If you have any other idea that can help i would really appreciate it. Maybe some other bios config like de AHCI or something?. My usb stick is in fat32 format with a puppy linux (that i just used in another pc and it works allraight)
    When i chose hdd i get showed both my hard drives (and some peripheral cards or something like that) but no usb.

    Thanks in advance

  7. Brilliant! Thanks so much.

  8. Nice one, thank you!!

  9. Your tip got me out of a big hole. Thank you!

  10. Thanks bro

  11. Thank you so much! The days I wasted on this. grrr
    There were so many other suggestions all over the internet such as 4gb partition sizes, type of usb stick, reverting back to old BIOS version (not going to try that) putting the stick in after BIOS booted and pressing F12 with the speed and timing of a racecar driver (boo didn’t work). The only other thing that did work for me to boot in DOS mode was:

    (It is very fussy about the MBR format)
    * Use a special tool to format the USB stick as a WIn98 startup disk (using Win98 startup disk files available via Google) and HP USB disk storage format tools .
    * Then it shows up in hdd boot order. In other formats (made with rufus) it doesn’t show up there at all and when I force it to read via usb-zip or usb-fdd I get error “invalid partition table’. :-(

    • jaja. this works after 8hs finally work I tried the same crazy things that you.
      thanks. blackmore

    • Rufus did it for me and doing F12 and choosing it from HDD+. I made a bootable Windows 10 using the Microsoft utility that downloads and creates the USB boot drive and my desktop with a Gigabyte GA-P35C-DS3R motherboard couldn’t see it. I downloaded the Windows 10 iso and used Rufus to create a bootable USB with the following settings: MBR scheme for both BIOS and UEFI-CSM, NTFS, left all teh format options checked and in Advanced Options clicked on “Add fixes for old BIOSes”

      I meant to do FAT32 but since it took a while to copy to the USB I figured I’d try it and it found the bootable drive without any timing of plugging in.

      • Thank you soooo much john this fixed the issue for me!

      • Thank you a lot! It worked also for me and my GA-880GA-UD3H MB. Hint for other, it is really relevant to which USB socket you will put your stick.

        On mine MB it worked on first USB near to PS2 mouse port (back of PC), others, including 3.0 where not working!

      • Thank you so much john, looks like socket 775 I found on the side of the road is going to live again

      • John- You rock. Finally got through on a GA-P35-DS3L. It must have been the NTFS part that did the trick. Wish I had seen this before I bricked a BIOS and had to pay 17 bucks for a 50 cent chip. :-(

      • This is the ONLY options that help me to fix it! Spent a few hours trying to run from usb flash (( Thanks you sooo much!!!

      • John’s steps worked for me, thank you soooooo much!!! The USB made with windows utility doesn’t work…. needed to download actual iso from a non windows system and then make the usb with John’s steps above with Rufus

      • Thanks! Using Rufus with MBR partition, and selecting it from the HDD+ menu did the trick for an old GA-P35-DS3L. Just a note that it seems like the front USB port did not work for me, had to use one in the back, near the LAN port. And even then it was quite slow to show the Windows 10 install screen (perhaps had I been more patient the front port would’ve worked)

      • Thanks! The main thing is to wait 10-15 min with black screen with blinking cursor.

  12. Unfortunately, this solution doesn’t work for me :(. For some reason, I don’t seem to have a ‘Network’ boot option, other than that the settings are the same. This really sucks, because I’ve been trying to install windows 10 via a flash drive for the last week with my computer seemingly fighting me at every turn. If you have any solution for this, please email me at b.danny012@gmail.com. Thanks in advance!

  13. MVP!

  14. That’s really helpful for me. thanks a lot.

  15. Thx m8

  16. I don’t have a Network option?

  17. No network option. jesus can’t one thing work for me ever

  18. What a legend!! Thanks so much! You saved my pic from being thrown down the street!

  19. Need Help ….It is not detected …IT doesnot show there…It only shows Hardisk

  20. Another thumbs UP to the man!

    I’ll just a couple of notes as my BIOS options were slightly different:

    The BIOS in my P35-DS3P motherboard only has one Integrated Peripherals to enable: Legacy USB storage detect

    The key boot order is “Hard Disk” (HDD in this article). When you press F12 to enter the Boot Menu, select “+ Hard Disk”. Do not be fooled by the various USB-*** options.

    It helps to check that your Live USB is actually bootable by testing on another non-Gigabyte computer/laptop. Good luck!

  21. You rock! Other than a different motherboard (GA-P55-UD4), my situation was EXACTLY the same as yours. Your solution worked perfectly, Step #7 was the trick.

  22. Thanks a lot bro. My motherboard was not exactly same as yours but it worked. I only changed the boot priority to USB and then booted as mentioned in step 7. Kudos!

  23. You are a lifesaver. Thank you so much

  24. Wow, I was beating my head trying to figure this out. Thank you so much!

  25. Great stuff, This had me beat for awhile

  26. hi man i have a gigabyte HT3.0 with dualbios, losing my mind over this, and the bios menu is not the same. It’s partitioned into MIT, system, Bios features, peripherals, power management, save and exit. never seen some bios like this.
    i used the same usb to install ubunto on my laptop, and works fine. i put in 1st place the “usb flash disk 1100” and disable the rest. have boot mode “legacy only”, LAN PXE disabled. i don’t even know what else to do, can someone help me?

    • Hey man, i have the same bios menu. And its so f*ucking bad couse i cant put my usb with windows 7, did you find a soulicion yet? Sorry for my bad english, i do why i can

  27. wise boss

  28. Thank you! Never knew that HDD+ offers more options!

  29. help please
    i dont have Integrated Peripherals > USB Legacy. or usb storage
    so when i do all this step i still dont find my usb drive

  30. That’s really helpful for me. thanks a lot.You made my day at work man thaaaaaaaaaaaanxx

  31. Tnx dude!!

  32. thank u , it was usefull

  33. Needless to say, you rock!

  34. dell boot key

  35. Hi i dont have USB Storage Devices option avaible in bios is like in white i have gigabyte uefi bios i dont know what is happening i cant enter windows if the fix is in windows. HELPPPP

  36. sorry but he not working for USB FAT or FAT32
    i use NTFS to work

  37. Really… just really… Flashed the bios spend weeks trying to find one that might work…… And the answer was use the HDD+ not the USB setting in the boot menu.. don’t know whether to slap you or kiss you. Cheers man.

  38. I’m reviving a my 10-year-old computer.
    Thx bro~

  39. Tried all the suggestions but still not working for me. I have a Gigabyte H110N with a Samsung SSD 500GB Drive, Bios Versoin F2 and a Windows 10 USB stick right out of the Microsoft packaging. I tried setting Fastboot to Full Initial which should make the USB drives known to POST but it didn’t work out. I just can’t find a way to get anything other than a “Insert media into boot device and reboot message”.


  40. By the sounds of that Peter N your first boot device may be set to a cdrom or floppy disk? You need to set first boot device as hard drive, and all the other steps above.
    Having fastboot turned on disables memory checking and speeds up booting which may be bad, you may need ninja timing to press F12 at boot time. If it’s booting into an OS, you may have difficulty entering BIOS setup too. If you can’t enter BIOS anymore, you could unplug your hard disk(s), or perhaps reset the CMOS. (That is if you are booting into anything, fastboot can also stop some motherboard detecting slower, older hard drives if it boots too fast!)

  41. You sir are a Legend!

  42. MD. Khairul Basar

    How to solve the issue for H81M-S2PV ?? Can’t find the options Boot order and USB Storage. Can someone help ?

  43. Really helpful thank you very much..

  44. I have noticed you don’t monetize your blog, don’t
    waste your traffic, you can earn additional bucks every month because you’ve
    got hi quality content. If you want to know how to
    make extra bucks, search for: Mertiso’s tips best adsense alternative

  45. Hi Mr “Whoever you are”

    I was almost giving up of finding a decent solution.
    Thank you very much for giving back my hope!
    Works like a charm!!!

    You saved my life! Love you!!

  46. Still helped me! These mobos still rock.

  47. Dude you’re a fucking legend! Thank you so much

  48. OoO Man.. thank you!!! I am without dvd driver and I trying to boot from usb days with out results. Thank you again..

  49. Thanks a lot!

  50. Hey blackmoreOPS. This didn’t really want to work for me. I have a GIGABYTE GA-MA785GMT-UD2H board. What I did was,

    I pressed the DELETE key to enter BIOS
    Then inserted my Bootable USB (created using YUMI).
    I then pressed Ctrl+Alt+delete to restart the computer.
    After POST, I pressed the F12 key and this gave a windows to select Boot First Device. I chose “+HDD” and then it gave me the options showing my USB.

    This is how it worked for me.

    Thanks for the help tho. I got some ideas from what you explained.
    God bless.

  51. If none of the above options worked out for you, insert usb into other ports if you have multiple ports. It worked for me.

  52. Awesome website bro for every educated people.

  53. Does not work. USB does not show up on the hdd as said on step 7. Usb is formated FAT32 and works on multiple other PCs. Motherboard is gigabyte ga-ma785gt-ud3h. Tried everything, I have started loosing faith in my self and started drinking again….

  54. The Really great post I healthful it very much here

    • Glad after all these years this post still helping people. I don’t have the other motherboards as many posted here for help, but please try to read the comments (John posted a great solution, James gave an alternative.. so on and forth) and hope your problem is resolved. In any case, try to post whatever worked for you for the next person. Thanks all for your kind comments.

  55. 9 years after the post and still great info ~ Thanks much!

  56. i’ve been working on it for about 2 weeks like crazy man and finally found your article, my stupid brain didn’t notice that we can still expand +Hdd in F12 boot option to choose booting from usb, thanks a lot, cheers!!!

  57. Hate to necro this thread but this worked on my 15 year old mb. Still a useful article.

  58. Thank you so much I didn’t know what to do and this fixed everything

  59. You are mad genius for this man! <a href=”https://www.houstonjackets.com/product/the-voice-s25-john-legend-black-embellished-bomber-jacket/

  60. Great Information! John Legend Embellished Bomber Jacket

Leave your solution or comment to help others.

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Discover more from blackMORE Ops

Subscribe now to keep reading and get access to the full archive.

Continue reading

Privacy Policy on Cookies Usage

Some services used in this site uses cookies to tailor user experience or to show ads.