Home / How to / Fixing dependency problems in Kali Linux

Fixing dependency problems in Kali Linux

Fixing dependency problems in Kali Linux

Kali Linux by Offensive Security
Kali Linux by Offensive Security

Like many forums and blogs people are hell bent on providing help without much explanation, (i.e. do this and it will be fixed, God! I hate solutions like that) and users end up with too many lines in their sources.list file.

Many users goes to Debian website and add the following repositories in Kali as specified in this page:

deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali-dev main contrib non-free
deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali-dev main/debian-installer
deb-src http://http.kali.org/kali kali-dev main contrib non-free

deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali main contrib non-free
deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali main/debian-installer
deb-src http://http.kali.org/kali kali main contrib non-free

deb [arch=i386,amd64,armel,armhf] http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

deb [arch=i386,amd64,armel,armhf] http://repo.kali.org/kali kali-bleeding-edge main
deb-src http://repo.kali.org/kali kali-bleeding-edge main

As I understand, first of all you don’t need to specify which architecture you’re using and neither do you have to add Bleeding Edge repositories unless you’re working on something that requires it. Following example was adapted from Kali Forums where a solution worked flawlessly.

Once you end up with a crappy sources.list file following is something similar what you’ll see when you do apt-get update or apt-get install something

W: Duplicate sources.list entry http://http.kali.org/kali/ kali/main amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://http.kali.org/kali/ kali/contrib amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_contrib_binary-amd64_Packages)
W: Duplicate sources.list entry http://http.kali.org/kali/ kali/non-free amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.kali.org/kali-security/ kali/updates/main amd64 Packages (/var/lib/apt/lists/security.kali.org_kali-security_dists_kali_updates_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.kali.org/kali-security/ kali/updates/contrib amd64 Packages (/var/lib/apt/lists/security.kali.org_kali-security_dists_kali_updates_contrib_binary-amd64_Packages)
W: Duplicate sources.list entry http://security.kali.org/kali-security/ kali/updates/non-free amd64 Packages (/var/lib/apt/lists/security.kali.org_kali-security_dists_kali_updates_non-free_binary-amd64_Packages)
W: You may want to run apt-get update to correct these problems

This is how an example sources.list looks like with duplicate entries:

# deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130905-07:57]/ kali contrib main non-free

#deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20130905-07:57]/ kali contrib main non-free

## Security updates
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free

deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali-dev main contrib non-free
deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali-dev main/debian-installer

deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali main contrib non-free
deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali main/debian-installer
deb http://repo.kali.org/kali kali-bleeding-edge main

deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://http.kali.org/kali kali main contrib non-free
deb-src http://http.kali.org/kali kali-dev main contrib non-free

The fix is rather easy, you just remove unnecessary lines from sources.list and stick with Kali Linux Official Repositories. This guide takes you through fixing you sources.list in Kali Linux.

Add official Kali Linux Repositories.

Hope this helps when you bump into similar issues.

 

Check Also

Correct way of installing VirtualBox Guest Additions in Kali Linux 2016.2/2017 (Kali Rolling)

How to install VirtualBox Guest Additions in Kali Linux (Kali Rolling / Kali Linux 2016.2 / Kali 2017)

Since Kali Linux 2016 came out (also known as Kali Rolling), it seems that Official …

Run Kali Linux in Microsoft Azure on SSD for free - blackMORE Ops - 1

Run Kali Linux in Microsoft Azure on SSD for free

Big news for Kali Linux users, now you can run Kali Linux in Microsoft Azure …

33 comments

  1. Your writing style is geeky and really good ! I like it. I think i am inspired by you. :) Thank You.

    • Thank you Fahad. Positive comment like this makes a great start of the day.

      • Hello blackmore! I messed up with trying to upgrade mixxx and somehow I’m filled with broken packages, gnome wiped out and many more deleted, how can I fix all broken packages?

        • apt-get -f install someting

          • # apt-get install -f gnome
            Reading package lists… Done
            Building dependency tree
            Reading state information… Done
            Some packages could not be installed. This may mean that you have
            requested an impossible situation or if you are using the unstable
            distribution that some required packages have not yet been created
            or been moved out of Incoming.
            The following information may help to resolve the situation:

            The following packages have unmet dependencies:
            gnome : Depends: gnome-core (= 1:3.4+7+deb7u1) but it is not going to be installed
            Depends: network-manager-gnome (>= 0.9.4) but it is not going to be installed
            Depends: aisleriot (>= 1:3.4) but it is not going to be installed
            Depends: cheese (>= 3.4) but it is not going to be installed
            Depends: evolution (>= 3.4) but it is not going to be installed
            Depends: evolution-plugins (>= 3.4) but it is not going to be installed
            Depends: file-roller (>= 3.4) but it is not going to be installed
            Depends: gedit (>= 3.4) but it is not going to be installed
            Depends: gnome-color-manager (>= 3.4) but it is not going to be installed
            Depends: gnome-documents (>= 0.4) but it is not going to be installed
            Depends: gnome-games (>= 1:3.4) but it is not going to be installed
            Depends: gnome-nettool (>= 3.2) but it is not going to be installed
            Depends: nautilus-sendto (>= 3.0) but it is not going to be installed
            Depends: gnome-orca (>= 3.4) but it is not going to be installed
            Depends: rygel-preferences (>= 0.14) but it is not going to be installed
            Depends: seahorse (>= 3.4) but it is not going to be installed
            Depends: totem (>= 3.0) but it is not going to be installed
            Depends: vinagre (>= 3.4) but it is not going to be installed
            Depends: alacarte (>= 0.13.4) but it is not going to be installed
            Depends: gnome-media (>= 3.4) but it is not going to be installed
            Depends: gnome-tweak-tool (>= 3.4) but it is not going to be installed
            Depends: rhythmbox (>= 2.96) but it is not going to be installed
            Depends: shotwell but it is not going to be installed
            Depends: simple-scan but it is not going to be installed
            Depends: sound-juicer (>= 3.4) but it is not going to be installed
            Depends: tracker-gui but it is not going to be installed
            Depends: transmission-gtk but it is not going to be installed
            Depends: xdg-user-dirs-gtk but it is not going to be installed
            Depends: gedit-plugins (>= 3.4) but it is not going to be installed
            Depends: gnome-applets (>= 3.4) but it is not going to be installed
            Depends: gnome-shell-extensions (>= 3.4) but it is not going to be installed
            Depends: rhythmbox-plugins but it is not going to be installed
            Depends: rhythmbox-plugin-cdrecorder but it is not going to be installed
            Depends: totem-plugins but it is not going to be installed
            Recommends: gdebi but it is not going to be installed
            Recommends: nautilus-sendto-empathy but it is not going to be installed
            E: Unable to correct problems, you have held broken packages.

          • Hi again number6,
            Instead of using apt-get install gnome, try using aptitude -r install gnome-core where -r installs recommended packages if any.
            Apart from that,
            Found this post: http://forums.debian.net/viewtopic.php?f=30&t=103818 which is exactly what your problem is … Hope it helps..

          • apt-get -f install someting

            is a very bad idea. I’ve detailed the reason why it is bad here: Install Skype.
            You should fix whatever dependency problems you have before you install new packages as it can only go bad to worse from this point.

        • apt-get install kali-linux-full ?

          or aptitude -r install kali-linux-full

          • :~# aptitude -r install gnome-core
            The following NEW packages will be installed:
            alacarte{a} baobab{a} brasero{a} caribou{a} caribou-antler{a} dconf-tools{a} empathy{a}
            empathy-common{a} eog{a} evince{a} evolution-data-server{a} fonts-cantarell{a} gcalctool{a} gcr{a}
            gdm3{a} gir1.2-caribou-1.0{a} gir1.2-clutter-1.0{a} gir1.2-clutter-gst-1.0{a} gir1.2-evince-3.0{a}
            gir1.2-gcr-3{ab} gir1.2-gkbd-3.0{a} gir1.2-gnomebluetooth-1.0{a} gir1.2-gtk-3.0{a}
            gir1.2-gtkclutter-1.0{a} gir1.2-gtksource-3.0{a} gir1.2-mutter-3.0{a} gir1.2-panelapplet-4.0{a}
            gir1.2-peas-1.0{a} gkbd-capplet{a} gnome-applets{a} gnome-backgrounds{a} gnome-bluetooth{a}
            gnome-contacts{a} gnome-control-center{ab} gnome-core gnome-dictionary{a} gnome-disk-utility{a}
            gnome-font-viewer{a} gnome-icon-theme{a} gnome-icon-theme-extras{a} gnome-icon-theme-symbolic{a}
            gnome-keyring{a} gnome-media{a} gnome-online-accounts{a} gnome-packagekit{a} gnome-packagekit-data{a}
            gnome-panel{a} gnome-power-manager{a} gnome-screensaver{a} gnome-screenshot{a} gnome-session{a}
            gnome-session-bin{a} gnome-session-fallback{a} gnome-settings-daemon{a} gnome-shell{a} gnome-sushi{a}
            gnome-system-log{a} gnome-system-monitor{a} gnome-terminal{a} gnome-themes-standard{a}
            gnome-user-guide{a} gnome-user-share{a} gstreamer0.10-plugins-bad{a} gucharmap{a} iceweasel{a}
            libavahi-gobject0{a} libavahi-ui-gtk3-0{a} libbrasero-media3-1{a} libcanberra-gtk3-0{a}
            libcanberra-gtk3-module{a} libcanberra-pulse{ab} libcaribou-gtk-module{a} libcaribou-gtk3-module{a}
            libcaribou0{a} libchamplain-0.12-0{a} libchamplain-gtk-0.12-0{a} libcheese-gtk21{a} libcheese3{a}
            libclutter-1.0-0{a} libclutter-gst-1.0-0{a} libclutter-gtk-1.0-0{a} libedata-book-1.2-13{a}
            libedataserverui-3.0-1{a} libevdocument3-4{a} libevview3-3{a} libfolks-eds25{a} libgail-3-0{a}
            libgcr-3-1{a} libgdict-1.0-6{a} libgdict-common{a} libgdu-gtk0{a} libgeocode-glib0{a}
            libgnome-bluetooth10{a} libgnome-desktop-3-2{ab} libgnome-media-profiles-3.0-0{a} libgnomekbd7{a}
            libgoa-1.0-0{ab} libgtk-3-0{ab} libgtk-3-bin{ab} libgtkmm-3.0-1{a} libgtksourceview-3.0-0{a}
            libgucharmap-2-90-7{a} libgweather-3-0{a} libmozjs24d{a} libmutter0{a} libmx-1.0-2{ab}
            libnautilus-extension1a{a} libnm-gtk0{a} libofa0{a} libpanel-applet-4-0{a} libpeas-1.0-0{a}
            libseed-gtk3-0{a} libtelepathy-farstream2{a} libunique-3.0-0{a} libvte-2.90-9{a}
            libwebkitgtk-3.0-0{ab} libwnck-3-0{a} libyelp0{a} metacity{a} mousetweaks{a} nautilus{ab}
            nautilus-sendto{a} nautilus-sendto-empathy{a} network-manager-gnome{a} notification-daemon{a}
            policykit-1-gnome{a} pulseaudio{ab} telepathy-gabble{a} telepathy-logger{a} telepathy-salut{a}
            tracker-gui{a} vino{a} xulrunner-24.0{a} yelp{a} zenity{a}
            The following partially installed packages will be configured:
            dpkg extlinux linux-image-686-pae
            The following packages are RECOMMENDED but will NOT be installed:
            pulseaudio-module-x11
            0 packages upgraded, 135 newly installed, 0 to remove and 12 not upgraded.
            Need to get 0 B of archives. After unpacking 335 MB will be used.
            The following packages have unmet dependencies:
            libgcr-base-3-1 : Breaks: libgcr-3-1 (< 3.8.2-2) but 3.4.1-3 is to be installed.
            nautilus : Depends: nautilus-data (< 3.5) but 1:3.8.2-0ubuntu2 is installed.
            pulseaudio : Depends: libpulse0 (= 2.0-6.1) but 1:4.0-0ubuntu6 is installed.
            gnome-control-center : Depends: gnome-control-center-data (< 1:3.5) but 1:3.6.3-0ubuntu44 is installed.
            libgoa-1.0-common : Breaks: libgoa-1.0-0 (< 3.8.2) but 3.4.2-2 is to be installed.
            gsettings-desktop-schemas : Breaks: gnome-shell (< 3.7.90) but 3.4.2-7+deb7u1 is to be installed.
            libfolks25 : Breaks: libfolks-eds25 (< 0.8.0-2~) but 0.6.9-1+b1 is to be installed.
            libgnome-desktop-3-2 : Depends: gnome-desktop3-data (= 3.4.2-1) but 3.8.4-0ubuntu1 is installed.
            libgtk-3-common : Breaks: libgtk-3-0 (< 3.5.4) but 3.4.2-7 is to be installed.
            libwebkitgtk-3.0-0 : Depends: libjavascriptcoregtk-3.0-0 (= 1.8.1-3.4) but 1.10.2-0ubuntu2 is installed.
            libgtk-3-0 : Depends: libgtk-3-common (= 3.4.2-7) but 3.8.4-0ubuntu3 is installed.
            libgoa-1.0-0 : Depends: libgoa-1.0-common (= 3.4.2-2) but 3.8.3-2 is installed.
            libmx-1.0-2 : Depends: libmx-common (= 1.4.6-1) but 1.4.7-0ubuntu2 is installed.
            Depends: libclutter-imcontext-0.1-0 but it is not going to be installed.
            Depends: libcluttergesture-0.0.2-0 but it is not going to be installed.
            libglib2.0-0 : Breaks: libgnome-desktop-3-2 (= 2.26)
            125) gnome-panel recommends gnome-control-center
            126) metacity recommends gnome-session | x-session-manager
            127) metacity recommends gnome-themes-standard
            128) mousetweaks recommends gnome-control-center
            129) nautilus-sendto-empathy recommends nautilus-sendto (>= 3.0)
            130) network-manager-gnome recommends gnome-keyring
            131) network-manager-gnome recommends gnome-bluetooth

            Accept this solution? [Y/n/q/?] y
            The following NEW packages will be installed:
            gstreamer0.10-plugins-bad{a} iceweasel{a} libmozjs24d{a} libofa0{a} xulrunner-24.0{a}
            The following partially installed packages will be configured:
            dpkg extlinux linux-image-686-pae
            0 packages upgraded, 5 newly installed, 0 to remove and 12 not upgraded.
            Need to get 0 B of archives. After unpacking 66.0 MB will be used.
            Do you want to continue? [Y/n/?] y
            E: I wasn’t able to locate a file for the linux-image-3.14-kali1-686-pae package. This might mean you need to manually fix this package.
            E: I wasn’t able to locate a file for the linux-image-3.14-kali1-686-pae package. This might mean you need to manually fix this package.
            E: Internal error: couldn’t generate list of packages to download

          • Are you on 32-bit or 64-bit? It seems like you’ve enabled 32-bit Arch on a 64-bit installation and then removed few packages in between.
            You need to resolve dependency for linux-image-3.14-kali1-686-pae package at current state. You could try to use -f but I don’t recommend it as by forcing an installation, you will break more stuffs.

            Also ensure you have the correct official repositories and did autoremove, autoclean as required.

  2. Dayum man, I seriously don’t know how much more time I would’ve wasted googling for solutions to problems you fix for me so easily! Thx for all the help!

  3. i had a similar problem but i used the synaptic packet managet to unistall the error and then did the dependency trick then reinstalled everything with aptitude install kali-linux-all and i had no issues and could update everything again. hope i saved someone a headache ^_^

    • aptitude or apt-get install synaptic to get the synaptic packet manager it helps to just paste the error into the search and use the gui, for me anyways.

  4. I can’t install wine in kali.
    when i running this command sudo aptitude -r install wine-bin:i386
    that time it will show
    leave this following dependencies and it’s up to 658 .
    Accept this solution[Y/n/q] ?
    what will i select?
    what to do to install succesfull wine. pls guys help me.

  5. pranaaaaaaaaaaaaaaaaaaab

    hey it worked! actually now i can run apt-get install linux-headers-$(uname -r) -y and make by virtual box addition working. Thanks!

  6. Problems with dependencies cause problemmy consequences and incorrectness of the entire distribution. For example: I set Opera 12.16 (funny: 64 platform set i386!) – but it becomes a “slanted” and needs to be updated, but the update Opera 28 deb – not possible!
    But this is not the only example! I am installing Tor. Collect it from Debian packages. Thor is going to, but does not start. Collect packets from the developer – a complete collapse at the end of the build, plus everything – Assemble of outdated packages. Install Google Earth – again depending! Of course, in addition to its own official repositories Kali, do not put aside, such as Ubuntu, Debian – Debian or Jesse – Hoarse … And just apply Kali for narrow purposes – security and hacking. But, guys, I find it funny to read all your instructions for Cali, of which actually works in practice, only 0.01% !!!
    In other words, “raw meat” – Kali, how many do not fix it, not make work properly! Too many mistakes. It reminds me in some ways the company “Nokia”. When Finns felt that in Europe make their phones – and very expensive, the first thing they did – move production to Asia: Vietnam, India, Singapore and Malaysia. As a result – fatal error: 404 (black, yellow and other Indians) can not be trusted to work with major industry! And as we all know, soon, “Nokia” neizmkrimye suffered losses and collapse.
    But, the “nothing to kill time,” correcting the mistakes of others, many times easier to take the perfect software – Runty, at its base to create a two – three steps Thor, as it once did my friend Edward Snowden, and break everything without tightness.
    Genius that – that simple! I have great respect for Blackmore, see his vast experience and a desire to create a decent distribution, as well as to help everyone who needs help – respect!
    However, it so happens that it is easier to throw in a landfill new imtrebitel Mig, in the end – all – blow it in the studio, what continues to work with mediocre created navigator and a failed gun! The same with the Cali … Is not it easier to take a “branch” of Knoppix and jostle there anything naprsno stuck in Cali. If 1.0.9 – still somehow able to work, then 1.1.0 – completely have no perspective on life! New Robolinux has a lot more than Kali, and the stability and speed – better than Debian hoarse ….
    But, as Socrates said, the truth is somewhere nearby and only in a dispute it is born … My best wishes to all developers, all “persistent and patient” programmers, who by the sweat and blood, in sleepless nights doing “our new future.” Especially the kind words and thanks – Blackmore!

  7. need help plsss…..

    root@K3rj:~# apt-get update
    Get:1 http://repo.kali.org kali-bleeding-edge Release.gpg [836 B]              
    Get:2 http://repo.kali.org kali-bleeding-edge Release [11.0 kB]     
    Get:3 http://repo.kali.org kali-bleeding-edge/main amd64 Packages [7,579 B]
    Hit http://security.kali.org kali/updates Release.gpg                          
    Hit http://http.kali.org kali Release.gpg       
    Get:4 http://http.kali.org kali-dev Release.gpg [836 B]                        
    Hit http://security.kali.org kali/updates Release                              
    Ign http://repo.kali.org kali-bleeding-edge/main Translation-en_PH             
    Hit http://http.kali.org kali Release                                          
    Ign http://repo.kali.org kali-bleeding-edge/main Translation-en                
    Get:5 http://http.kali.org kali-dev Release [21.1 kB]                          
    Hit http://security.kali.org kali/updates/main Sources                         
    Hit http://security.kali.org kali/updates/contrib Sources                      
    Hit http://http.kali.org kali/main Sources                                     
    Hit http://security.kali.org kali/updates/non-free Sources                     
    Hit http://http.kali.org kali/non-free Sources                                 
    Hit http://security.kali.org kali/updates/main amd64 Packages                  
    Hit http://http.kali.org kali/contrib Sources                                  
    Hit http://security.kali.org kali/updates/contrib amd64 Packages               
    Get:6 http://http.kali.org kali/main amd64 Packages [8,474 kB]                 
    Ign http://security.kali.org kali/updates/contrib Translation-en_PH            
    Hit http://security.kali.org kali/updates/non-free amd64 Packages              
    Ign http://security.kali.org kali/updates/contrib Translation-en               
    Ign http://security.kali.org kali/updates/main Translation-en_PH               
    Get:7 http://http.kali.org kali/non-free amd64 Packages [138 kB]               
    Ign http://security.kali.org kali/updates/main Translation-en                  
    Ign http://security.kali.org kali/updates/non-free Translation-en_PH           
    Get:8 http://http.kali.org kali/contrib amd64 Packages [57.7 kB]      
    Ign http://security.kali.org kali/updates/non-free Translation-en              
    Get:9 http://http.kali.org kali/main/debian-installer amd64 Packages [74.8 kB] 
    Get:10 http://http.kali.org kali/main armel Packages [8,284 kB]                
    Ign http://http.kali.org kali/contrib Translation-en_PH                                                                                              
    Ign http://http.kali.org kali/contrib Translation-en                                                                                                 
    Ign http://http.kali.org kali/main Translation-en_PH                                                                                                 
    Ign http://http.kali.org kali/main Translation-en                                                                                                    
    Ign http://http.kali.org kali/main/debian-installer Translation-en_PH                                                                                
    Ign http://http.kali.org kali/main/debian-installer Translation-en                                                                                   
    Ign http://http.kali.org kali/non-free Translation-en_PH                                                                                             
    Ign http://http.kali.org kali/non-free Translation-en                                                                                                
    Get:11 http://http.kali.org kali/contrib armel Packages [45.2 kB]                                                                                    
    Ign http://http.kali.org kali-dev/contrib Translation-en_PH                                                                                          
    Ign http://http.kali.org kali-dev/contrib Translation-en                                                                                             
    Get:12 http://http.kali.org kali/non-free armel Packages [91.2 kB]                                                                                   
    Ign http://http.kali.org kali-dev/main Translation-en_PH                                                                                             
    Ign http://http.kali.org kali-dev/main Translation-en                                                                                                
    Get:13 http://http.kali.org kali/main/debian-installer armel Packages [83.4 kB]                                                                      
    Ign http://http.kali.org kali-dev/main/debian-installer Translation-en_PH                                                                            
    Ign http://http.kali.org kali-dev/main/debian-installer Translation-en                                                                               
    Ign http://http.kali.org kali-dev/non-free Translation-en_PH                                                                                         
    Ign http://http.kali.org kali-dev/non-free Translation-en                                                                                            
    Get:14 http://http.kali.org kali/main armhf Packages [7,716 kB]                                                                                      
    Get:15 http://http.kali.org kali/contrib armhf Packages [42.2 kB]                                                                                    
    Get:16 http://http.kali.org kali/non-free armhf Packages [86.7 kB]                                                                                   
    Get:17 http://http.kali.org kali/main/debian-installer armhf Packages [67.8 kB]                                                                      
    Get:18 http://http.kali.org kali/main i386 Packages [8,500 kB]                                                                                       
    Get:19 http://http.kali.org kali/contrib i386 Packages [58.4 kB]                                                                                     
    Get:20 http://http.kali.org kali/non-free i386 Packages [134 kB]                                                                                     
    Get:21 http://http.kali.org kali/main/debian-installer i386 Packages [88.2 kB]                                                                       
    Get:22 http://http.kali.org kali-dev/main Sources [9,134 kB]                                                                                         
    Get:23 http://http.kali.org kali-dev/contrib Sources [59.5 kB]                                                                                       
    Get:24 http://http.kali.org kali-dev/non-free Sources [123 kB]                                                                                       
    Get:25 http://http.kali.org kali-dev/main amd64 Packages [9,580 kB]                                                                                  
    Get:26 http://http.kali.org kali-dev/contrib amd64 Packages [62.5 kB]                                                                                
    Get:27 http://http.kali.org kali-dev/non-free amd64 Packages [122 kB]                                                                                
    Get:28 http://http.kali.org kali-dev/main/debian-installer amd64 Packages [69.2 kB]                                                                  
    Get:29 http://http.kali.org kali-dev/main armel Packages [9,367 kB]                                                                                  
    Get:30 http://http.kali.org kali-dev/contrib armel Packages [45.9 kB]                                                                                
    Get:31 http://http.kali.org kali-dev/non-free armel Packages [87.4 kB]                                                                               
    Get:32 http://http.kali.org kali-dev/main/debian-installer armel Packages [73.1 kB]                                                                  
    Get:33 http://http.kali.org kali-dev/main armhf Packages [9,079 kB]                                                                                  
    Get:34 http://http.kali.org kali-dev/contrib armhf Packages [44.5 kB]                                                                                
    Get:35 http://http.kali.org kali-dev/non-free armhf Packages [85.8 kB]                                                                               
    Get:36 http://http.kali.org kali-dev/main/debian-installer armhf Packages [65.7 kB]                                                                  
    Get:37 http://http.kali.org kali-dev/main i386 Packages [9,588 kB]                                                                                   
    Get:38 http://http.kali.org kali-dev/main i386 Packages [9,588 kB]                                                                                   
    Get:39 http://http.kali.org kali-dev/main i386 Packages [9,588 kB]                                                                                   
    Get:40 http://http.kali.org kali-dev/contrib i386 Packages [61.8 kB]                                                                                 
    Get:41 http://http.kali.org kali-dev/non-free i386 Packages [117 kB]                                                                                 
    Get:42 http://http.kali.org kali-dev/main/debian-installer i386 Packages [76.1 kB]                                                                   
    Fetched 74.8 MB in 9min 23s (133 kB/s)                                                                                                               
    Reading package lists... Done
    W: Duplicate sources.list entry http://http.kali.org/kali/ kali/main amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_main_binary-amd64_Packages)
    W: Duplicate sources.list entry http://http.kali.org/kali/ kali/contrib amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_contrib_binary-amd64_Packages)
    W: Duplicate sources.list entry http://http.kali.org/kali/ kali/non-free amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_non-free_binary-amd64_Packages)
    W: You may want to run apt-get update to correct these problems
    • Did you read the error message?

      W: Duplicate sources.list entry http://http.kali.org/kali/ kali/main amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_main_binary-amd64_Packages)
      W: Duplicate sources.list entry http://http.kali.org/kali/ kali/contrib amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_contrib_binary-amd64_Packages)
      W: Duplicate sources.list entry http://http.kali.org/kali/ kali/non-free amd64 Packages (/var/lib/apt/lists/http.kali.org_kali_dists_kali_non-free_binary-amd64_Packages)
      W: You may want to run apt-get update to correct these problems
      

      Also, Why Bleeding Edge? Are you a programmer? You got too much in your sources.list that doesn’t do any good.
      Just add official Kali Linux Repositories (remove everything you have now) and you will be fine.

  8. my problem ::
    This version includes a new hid2hci program which expects the vendor ID and
    product ID of the device to be switched to HID/HCI mode, this means the
    switching is no longer done in init script but via udev rules for supported
    devices. Adding new devices can be done by dropping rules into
    /etc/udev/rules.d/ similar to ones found in
    /lib/udev/rules.d/62-bluez-hid2hci.rules or by manually running hid2hci, see
    hid2hci(8) manpage for further information.

    what i have to do?

  9. root@kali:~# apt-key adv –keyserver hkp://keys.gnupg.net –recv-keys 7D8D0BF6
    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –secret-keyring /tmp/tmp.uSQzs7O4hk –trustdb-name /etc/apt//trustdb.gpg –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg –keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg –keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-automatic.gpg –keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg –keyring /etc/apt/trusted.gpg.d//kali-archive-keyring.gpg –keyserver hkp://keys.gnupg.net –recv-keys 7D8D0BF6
    gpg: requesting key 7D8D0BF6 from hkp server keys.gnupg.net
    gpg: keyserver timed out
    gpg: keyserver receive failed: keyserver error
    root@kali:~#

    what should i do?

  10. hey DUMBFUCK you should remove the “this page” that is highlighted blue the files on that page WILL WRECK YOUR KALI it changes it to gnome FULL and when reverting back to kali fallback it changes your drive to READ ONLY THANKS TO YOU I HAD TO RESTORE MY FUCKING COMPUTER I STG IF I FIND OUT YOUR NAME IM GOING TO RAPE YOUR ENTIRE FAMILY AN SLIT THERE THROATS RIGHT IN FRONT OF YOU I LOST EVERYTHING BECAUSE OF YOU!

    • Hi Zodiac,
      Yes, I would be pissed too if something like that happened but that section as specific to another users problem (very different to your one where someone was trying to install gnome-full with an -f flag).
      The only reason your HDD might’ve been turned to read-onl if you’re using LUKS or entire disk encryption or something similar. And even with that, (read only HDD, very weird though, I’ve seen fried HDD but nothing like what you’ve described), all you had to do is boot is a secondary drive and copy things across. You could’ve even used a Live USB to boot (as Live USB boots into Memory) and mount the disk as read-only and copy things across/attempt to fix. Sorry for your loss but if you search around, your issue seems to be very unique and once off.
      -BMO

  11. i have a problem, pleasa help me..

    W: GPG error: http://http.kali.org kali Release: The following signatures were invalid: KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400
    W: GPG error: http://security.kali.org kali/updates Release: The following signatures were invalid: KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400

  12. The following packages have unmet dependencies:
    libcupsimage2 : Depends: libcups2 (= 1.7.5-11) but 1.7.5-11+deb8u1 is installed.
    The following actions will resolve these dependencies:

    Keep the following packages at their current version:

    1) evince [Not Installed]
    2) gir1.2-evince-3.0 [Not Installed]
    3) gnome-core [Not Installed]
    4) gnome-sushi [Not Installed]
    5) libcupsfilters1 [Not Installed]
    6) libcupsimage2 [Not Installed]
    7) libevdocument3-4 [Not Installed]
    8) libevview3-3 [Not Installed]
    9) libgs9 [Not Installed]
    10) libspectre1 [Not Installed]
    how to fix this

  13. Really THANK YOU SO MUCH dude you did than i don’t reinstall my system.

  14. hi sir.when i tried to install libreoffice,openoffice etc(ie msoffice alternatives) in kali linux..its showing unmet dependencies..
    root@debian:~# apt-get -f install libreoffice
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libreoffice : Depends: fonts-sil-gentium-basic but it is not installable
    Depends: libreoffice-base but it is not going to be installed
    Depends: libreoffice-calc but it is not going to be installed
    Depends: libreoffice-core (= 1:4.3.3-2+deb8u2) but it is not going to be installed
    Depends: libreoffice-draw but it is not going to be installed
    Depends: libreoffice-impress but it is not going to be installed
    Depends: libreoffice-math but it is not going to be installed
    Depends: libreoffice-report-builder-bin but it is not going to be installed
    Depends: libreoffice-writer but it is not going to be installed
    Depends: libreoffice-avmedia-backend-gstreamer but it is not going to be installed or
    libreoffice-avmedia-backend-vlc but it is not going to be installed
    Depends: python3-uno (>= 4.0~) but it is not going to be installed or
    python-uno but it is not going to be installed
    E: Unable to correct problems, you have held bro
    E: Unable to correct problems, you have held broken packages.
    pls do reply..its urgent for me..

  15. i am trying to install gdebi package installer in kali 2.0 . but it is showing dependency problem . i am using dpkg -i filename.deb

  16. dinesh sharma why dont you just reinstall a kali weekly build ? november 2016 its updated to http://cdimage.kali.org/kali-images/kali-weekly/

    im using kali-linux-2016-W46-i386.iso on my usb with luks
    and kali-linux-2016-W46-amd64.iso on my hdd

  17. then add these to etc/apt/sources.list

    deb http://http.kali.org/kali kali-rolling main contrib non-free
    deb-src http://http.kali.org/kali kali-rolling main contrib non-free
    deb http://http.kali.org/kali kali-bleeding-edge contrib non-free main
    deb http://repo.kali.org/kali kali-bleeding-edge main

    and then do
    apt-get update && apt-get upgrade

    nice updated o/s then ;) install anonsurf and you should be good

  18. HEY CAN ANYONE SHOW ME THE BEST Repositories for kali 2.0 sana

  19. after update my system is not opening. it stops with the first page itself. it shows like this
    Recovering journal
    a start job is running device manager
    dependency failed for swap

    Plz help me…it sucks

  20. Hello, I really need help with this. Kali will not let me use apt-get install anything.

    Every time I try it I get these errors:

    The following packages have unmet dependencies:
    cpp-5 : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed
    cpp-6 : Depends: gcc-6-base (= 6.2.0-5ubuntu12) but 6.3.0-8 is installed
    g++-6 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    gcc-5 : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed
    gcc-6 : Depends: cpp-6 (= 6.1.1-11) but 6.2.0-5ubuntu12 is installed
    Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libasan2 : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed
    libasan3 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libatomic1 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libcc1-0 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libcilkrts5 : Depends: gcc-6-base (= 6.1.1-11) but 6.3.0-8 is installed
    libgcc-5-dev : Depends: gcc-5-base (= 5.4.1-1) but 5.4.1-7 is installed

    There are actually about 20-25 more but all requiring the same gcc-5 & 6 base files. I can’t find any where to download and install those older versions. I’ve spent numerous hours on this.

    I’ve tried all the apt-get update && apt-get upgrade, apt-get autoremove, apt-get -f install, and everything else I can find online. I also have updated my sources.list to reference deb http://http.kali.org/kali kali-rolling main contrib non-free. I’m very new to Kali. I installed a bunch of deb files to get my wifi card working which it is now finally working.

    Please help me get my apt-get install working.

Use WordPress.com, Twitter, Facebook, or Google+ accounts to comment (anonymous comments allowed)

This site uses Akismet to reduce spam. Learn how your comment data is processed.